Selain menambah kinerja dari CPU, area yang terlalu banyak router akan menyebabkan terlalu seringya update routing tabel, sehingga membebani jaringan dan CPU.
Menggunakan OSPF multiarea akan meringankan kinerja dari router. Dalam multiarea dikenal backbone area dan regular area. Backbone area merupakan area yang digunakan untuk menghubungkan antar area. Sering disebut sebagai area 0.
Selain area 0 atau area backbone, maka disebut sebagai regualar area atau non-backbone area. Regular area dibagi beberapa seperti Stub, totally stubby, and NSSAs.
Untuk mengoptimalkan kerja OSPF, setiap area tidak boleh melebihi dari 50 router, setiap router cukup terhubung dengan maksimal 3 area dan setiap router maksimum cukup 60 router neighbors.
Dalam OSPF terdapat 4 tipe router, yakni internal router, backbone router, Area Border Router, dan Autonomous System Boundary Router.
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface GigabitEthernet0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface gigabitEthernet 0/1
R1(config-if)#ip address 13.13.13.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface gigabitEthernet 0/2
R1(config-if)#ip address 14.14.14.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
#Mengaktifkan OSPF dengan process-id 10
R1(config)#router ospf 10
#Menambah Router-id 1.1.1.1
R1(config-router)#router-id 1.1.1.1
#Mendefinisikan masing-masing network yang saling
#terhubung dengan router tetangga.
#Setiap network mempunyai area sendiri
R1(config-router)#network 14.14.14.0 0.0.0.3 area 0
R1(config-router)#network 12.12.12.0 0.0.0.3 area 12
R1(config-router)#network 13.13.13.0 0.0.0.3 area 13
R1#
Konfigurasi R3
Router#configure terminal
Router(config)#hostname
Router(config)#hostname R2
R2(config)#interface GigabitEthernet0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router ospf 10
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 12.12.12.0 0.0.0.3 area 12
R2#
Konfigurasi R3
Router#configure terminal
Router(config)#hostname
Router(config)#hostname R3
R3(config)#interface GigabitEthernet 0/1
R3(config-if)#ip address 13.13.13.2 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router ospf 10
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 13.13.13.0 0.0.0.3 area 13
R3#
Konfigurasi R4
Router#configure terminal
Router(config)#hostname
Router(config)#hostname R4
R4(config)#interface GigabitEthernet 0/0
R4(config-if)#ip address 14.14.14.2 255.255.255.252
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface GigabitEthernet 0/1
R4(config-if)#ip address 45.45.45.1 255.255.255.252
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#router ospf 10
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 14.14.14.0 0.0.0.3 area 0
R4(config-router)#network 45.45.45.0 0.0.0.3 area 45
R4#
Konfigurasi R5
Router#configure terminal
Router(config)#hostname
Router(config)#hostname R5
R5(config)#interface GigabitEthernet 0/0
R5(config-if)# ip address 45.45.45.2 255.255.255.252
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#router ospf 10
R5(config-router)#router-id 5.5.5.5
R5(config-router)#network 45.45.45.0 0.0.0.3 area 45
R5#
Pengujian
Pengujian bisa menggunakan sintaks show ip ospf neighbor, show ip ospf, show ip ospf interface, show ip protocols, show ip ospf interface brief, show ip route ospf, show ip ospf database
R1#show ip protocols
Routing Protocol is "ospf 10"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 1.1.1.1
Number of areas in this router is 3. 3 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
14.14.14.0 0.0.0.3 area 0
12.12.12.0 0.0.0.3 area 12
13.13.13.0 0.0.0.3 area 13
Routing Information Sources:
Gateway Distance Last Update
1.1.1.1 110 00:13:42
2.2.2.2 110 00:14:19
3.3.3.3 110 00:13:43
4.4.4.4 110 00:22:50
Distance: (default is 110)
R1#
R1#show ip ospf
Routing Process "ospf 10" with ID 1.1.1.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
It is an area border router
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 3. 3 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm executed 18 times
Area ranges are
Number of LSA 8. Checksum Sum 0x04c8a4
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 12
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm executed 13 times
Area ranges are
Number of LSA 6. Checksum Sum 0x028a3f
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 13
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm executed 9 times
Area ranges are
Number of LSA 6. Checksum Sum 0x02d8da
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
R1#
R1#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
4.4.4.4 1 FULL/DR 00:00:31 14.14.14.2 GigabitEthernet0/2
2.2.2.2 1 FULL/BDR 00:00:38 12.12.12.2 GigabitEthernet0/0
3.3.3.3 1 FULL/BDR 00:00:39 13.13.13.2 GigabitEthernet0/1
R1#
R1#sh ip ospf database
OSPF Router with ID (1.1.1.1) (Process ID 10)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 2872 0x8000000d 0x003eae 1
1.1.1.1 1.1.1.1 1038 0x8000000c 0x00f9ef 1
4.4.4.4 4.4.4.4 1451 0x80000004 0x0033a5 1
Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
12.12.12.2 2.2.2.2 2872 0x80000002 0x00f12f
14.14.14.2 4.4.4.4 1571 0x80000002 0x0095dd
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
12.12.12.0 1.1.1.1 1009 0x80000006 0x00a78c
13.13.13.0 1.1.1.1 973 0x80000007 0x0081ae
45.45.45.0 4.4.4.4 1447 0x80000002 0x00ac1c
Router Link States (Area 12)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 940 0x80000007 0x008279 1
2.2.2.2 2.2.2.2 940 0x80000003 0x0048af 1
Net Link States (Area 12)
Link ID ADV Router Age Seq# Checksum
12.12.12.1 1.1.1.1 940 0x80000002 0x00d7d3
Summary Net Link States (Area 12)
Link ID ADV Router Age Seq# Checksum
14.14.14.0 1.1.1.1 1175 0x80000006 0x005fce
45.45.45.0 1.1.1.1 1175 0x80000007 0x0007c7
13.13.13.0 1.1.1.1 974 0x80000008 0x007faf
Router Link States (Area 13)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 903 0x80000005 0x00c235 1
3.3.3.3 3.3.3.3 904 0x80000003 0x0038b1 1
Net Link States (Area 13)
Link ID ADV Router Age Seq# Checksum
13.13.13.1 1.1.1.1 903 0x80000002 0x00ccd4
Summary Net Link States (Area 13)
Link ID ADV Router Age Seq# Checksum
14.14.14.0 1.1.1.1 1061 0x80000005 0x0061cd
45.45.45.0 1.1.1.1 1061 0x80000006 0x0009c6
12.12.12.0 1.1.1.1 1008 0x80000007 0x00a58d
R1#
R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/30 is directly connected, GigabitEthernet0/0
L 12.12.12.2/32 is directly connected, GigabitEthernet0/0
13.0.0.0/30 is subnetted, 1 subnets
O IA 13.13.13.0/30 [110/2] via 12.12.12.1, 00:49:09, GigabitEthernet0/0
14.0.0.0/30 is subnetted, 1 subnets
O IA 14.14.14.0/30 [110/2] via 12.12.12.1, 00:49:09, GigabitEthernet0/0
45.0.0.0/30 is subnetted, 1 subnets
O IA 45.45.45.0/30 [110/3] via 12.12.12.1, 00:49:09, GigabitEthernet0/0
R2#
Pengujian melihat apakah neighbour router-id sudah masuk kedalam R1, selanjutnya pengujian dengan melihat routing table. Flag O IA merupakan hasil generate routing OSPF
0 comments:
Post a Comment